Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-1717

Huge performance problem with the calendar component in IE 6

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: 3.1.3
    • Fix Version/s: 3.1.4, 3.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      IE v6.0.2900.2180.xpxp_sp2_rtm.040803-2158
      Firefox v2.0.0.11
      JSF RI 1.2_07
      Facelets 1.1.13
      Seam 1.2.1
      Richfaces 3.1.3
      WebSphere v6.1.0.13

      Description

      We have a huge performance problem with the calendar component in v3.1.3 and IE (version v6.0.2900.2180.xpxp_sp2_rtm.040803-2158)

      It can take 10 to 30 seconds for IE to display a page that contains with a rich:calendar component where the IE process is using 100% of the cpu

      The problem does not occur with firefox v2.0.0.11

      Also if we look at the memory usage of the IEXPLORE process, that grow constantly each time we click on a page that use that component, it seems also that a memory leak is occurring

        Gliffy Diagrams

          Issue Links

            Activity

            przemjaskier Przemyslaw Jaskierski added a comment -

            RF-1941, please vote.

            wbervoet Wim Bervoets added a comment -

            Denis,

            I can't reopen this jira (only the creator and people from JBoss can do this I think). If I find out why some IE6 have this problem and others not I'll update this jira.

            It's ok for me to do the optional performance optimalizations in a general way in RF-1941. (going to vote for it )

            Wim

            kiwi17 Christian Küppers added a comment -

            I have opened a new issue for the performance problem with the panel menu component.

            Christian

            wbervoet Wim Bervoets added a comment -

            We've noticed that IE6 javascript performance & using 100% CPU time is a lot better after you install the latest version of JScript: http://support.microsoft.com/kb/919237

            bazu bazu added a comment -

            The problem is also with rich:tree inside a rich:modalPanel. I use 3.1.3 GA. and, of course, IE6


              People

              • Assignee:
                ayanul Aleksej Yanul
                Reporter:
                titou09 Denis Forveille
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development