Uploaded image for project: 'Seam 2'
  1. Seam 2
  2. JBSEAM-2746

Hibernate Search doesn't update index correctly

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.2.0.CR1
    • Component/s: Wiki
    • Labels:
      None

      Description

      We have a long outstanding bug that affects the search. Apparently there are indexed items that have long been deleted. Or the indexing is wrong in some way (which is more likely, because almost nothing gets ever deleted):

      22:00:34,766 DEBUG [ObjectLoader] Object found in Search index but not in database: class org.jboss.seam.wiki.core.model.WikiDocument wih id 11139
      22:00:34,769 DEBUG [ObjectLoader] Object found in Search index but not in database: class org.jboss.seam.wiki.core.model.WikiDocument wih id 11219
      22:00:34,771 DEBUG [ObjectLoader] Object found in Search index but not in database: class org.jboss.seam.wiki.core.model.WikiDocument wih id 11224

      It's hard to tell what the "Object" was because I can't see any useful data about it in the index.

      This is unlikely to be resolved soon, I wouldn't even know where to start looking. It's all fixed by rebuilding the search index in the admin screen manually from time to time. So if someone complains about the search results, rebuild the index.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  christian.bauer Christian Bauer
                  Reporter:
                  nickarls Nicklas Karlsson
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: