Uploaded image for project: 'JBRULES'
  1. JBRULES
  2. JBRULES-1336

Typo in RuleBaseConfiguration(ClassLoader classLoder, Properties properties) -- the ClassLoader specified in the constructor args is not used

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.0.3
    • Fix Version/s: 4.0.4, 5.0.0.M1
    • Component/s: None
    • Labels:
      None

      Description

      The RuleBaseConfiguration constructor:

          public RuleBaseConfiguration(ClassLoader classLoder,
                                       Properties properties) {
              init( classLoader,
                    properties );
          }
      

      contains a typo--the call to init should pass the (mis-spelled) classLoder, not the member field classLoader. As it is, the null member field is passed instead, resulting in the given ClassLoader instance being unused. Trivial fix: Just correct the spelling of the constructor arg name:

          public RuleBaseConfiguration(ClassLoader classLoader,
                                       Properties properties) {
              init( classLoader,
                    properties );
          }
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  tirelli Edson Tirelli
                  Reporter:
                  jwsparrowubs James Sparrow
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: