Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-2327

Seam Validator looking for non existing "startup" property

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.1.1
    • Fix Version/s: 2.1.2
    • Component/s: seam2
    • Labels:
      None

      Description

      All my components configured in components.xml get a seam validator error

      class <classname> of component <componentName> does not contain setter for property "startup"

      Off course these components don't contain a startup property and the configuration in components.xml doesn't mention startup either.

      For instance

      <component name="sessionHdl">
      <property name="pro">false</property>
      </component>

      Trigger the bug.
      This problem started with JBoss Tools 2.1.0.GA and is stil present in 2.1.1, downgrading to 2.0.1.GA correct the problem. So it looks like a regression bug

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  scabanovich Viacheslav Kabanovich
                  Reporter:
                  antoinesabot-durand Antoine Sabot-Durand
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: