Uploaded image for project: 'JBoss ESB'
  1. JBoss ESB
  2. JBESB-391

sometimes the parser is not found when doing a parameter reload.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Optional
    • Resolution: Duplicate Issue
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0
    • Component/s: Rosetta
    • Labels:
      None
    • Environment:

      any

      Description

      When running the deployToSar task of the hello world quickstart on a running jboss, the timestamp on the jbossesb.xml changes and the parameters are reloaded. When this happens sometimes see the following stacktrace:

      15:18:25,687 INFO [Server] JBoss (MX MicroKernel) [4.0.5.GA (build: CVSTag=Branch_4_0 date=200610162339)] Started in 40s:875ms
      15:18:47,296 ERROR [STDERR] Exception in thread "Thread-6"
      15:18:47,296 ERROR [STDERR] org.apache.xerces.parsers.ObjectFactory$ConfigurationError: Provider org.apache.xerces.parsers.XIncludeAwareParserConfiguration could not be instantiated: java.lang.NullPointerException
      15:18:47,296 ERROR [STDERR] at org.apache.xerces.parsers.ObjectFactory.newInstance(Unknown Source)
      15:18:47,296 ERROR [STDERR] at org.apache.xerces.parsers.ObjectFactory.createObject(Unknown Source)
      15:18:47,296 ERROR [STDERR] at org.apache.xerces.parsers.ObjectFactory.createObject(Unknown Source)
      15:18:47,296 ERROR [STDERR] at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)
      15:18:47,296 ERROR [STDERR] at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)
      15:18:47,296 ERROR [STDERR] at org.apache.xerces.jaxp.DocumentBuilderImpl.<init>(Unknown Source)
      15:18:47,296 ERROR [STDERR] at org.apache.xerces.jaxp.DocumentBuilderFactoryImpl.newDocumentBuilder(Unknown Source)
      15:18:47,296 ERROR [STDERR] at org.jboss.soa.esb.listeners.config.XmlValidatorImpl.validate(XmlValidatorImpl.java:160)
      15:18:47,296 ERROR [STDERR] at org.jboss.soa.esb.listeners.config.ConfigurationController.processConfiguration(ConfigurationController.java:176)
      15:18:47,296 ERROR [STDERR] at org.jboss.soa.esb.listeners.config.ConfigurationController.run(ConfigurationController.java:113)
      15:18:47,296 ERROR [STDERR] at java.lang.Thread.run(Thread.java:595)
      15:19:12,515 ERROR [STDERR] Exception in thread "Thread-15"

      which is thrown from the line 160 in the XmlValidatorImpl:

      parser = builderFactory.newDocumentBuilder();

      The issue seems to fix it self, as it seems to be successful 5 seconds later.

        Gliffy Diagrams

          Issue Links

            Activity

            kurtstam Kurt Stam added a comment -

            This has to do with the undeploying the sar. When the jboss-service.xml is touched, the sar reloads, the MBeans are stopped which call unregister on the listener and gateways. The unregister is not successful because of classloading issues.

            If the jbossesb.xml is emptied the listeners unregister nicely. This clearly is a timing issue.

            Not sure how to get around this.

            kurtstam Kurt Stam added a comment -

            This is also why sometimes the registry becomes unavailable on sar redeployes.

            marklittle Mark Little added a comment -

            Moved this to 'optional' because it appears to be an intermittent issue.

            kurtstam Kurt Stam added a comment -

            Well it is intermittend if reading the configuration fails, however as I stated in later this is more of a general issue with reloading the sar and it can fail anywhere, so I don't think this should be marked as optional. Maybe we should rename this issue.

            Kev says:

            "I am in the middle of rewriting how the gateways/listeners are
            initialised/tracked etc. This will have an effect on any redeployment
            of the services."

            kconner Kevin Conner added a comment -

            This issue was caused by a thread remaining active after the associated classloader had been undeployed.

            This has been fixed by the lifecycle changes, JBESB-357


              People

              • Assignee:
                kconner Kevin Conner
                Reporter:
                kurtstam Kurt Stam
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development