Uploaded image for project: 'Application Server 3  4  5 and 6'
  1. Application Server 3 4 5 and 6
  2. JBAS-4510

Upgrade jboss remoting to v2.2.1.GA (from v2.2.0.SP4)

    XMLWordPrintable

    Details

      Description

      Upgrade jboss remoting to 2.2.1.GA to incorporate some nice (and backwards compatible fixes):

      JBREM-747: "org.jboss.remoting.transport.Connector should unregister server invoker from MBeanServer"
      JBREM-748: "BisocketClientInvoker should guard agains scheduling on an expired Timer"
      JBREM-751: "Eliminate unnecessary "Unable to process control connection:" message from BisocketServerInvoker"
      JBREM-761: "NPE in BisocketServerInvoker$ControlConnectionThread"

      Ron has also added a 2.2.1.GA <--> 2.2.0.SP4 compatibility test to the Remoting compatibility test suite. 2.2.1.GA is compatible back to 1.4.3.GA, which covers JBossAS 4.0.4, 4.0.5, and 4.2.0.

      Thanks Ron.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                dimitris Dimitris Andreadis
                Reporter:
                dimitris Dimitris Andreadis
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: